Blue Flower

Excel bietet zwei Funktion das erste Vorkommen eines Zeiches zu finden.
mit der Funktion Finden wird die Groß- und Kleinschreibung unterschieden mit der Funktion Suchen nicht.
Wenn jetzt aber das 2., 3. etc. Vorkommen des Zeichens gesucht wird es deutlich schwieriger wenn es Variable gehalten werden soll.
Das Prizip wird im Artikel "Letztes Vorkommen eines Zeichens im Text" erklärt. Im Feld A1 ist der zu durchsuchende Text. In Feld A2 die zu suchende Zeichenfolge. In A3 steht wie weit in der Trefferliste gesprungen werden soll. Leer entspricht 0. Wird ein Wert größer des maximalen Trefers eingetragen so wird der letzte Treffer genommen.

A1 = "Guten Morgen liebe Sorgen"
A2 = "en"
A3 = 2

11   =WENNFEHLER(FINDEN("|";WECHSELN(KLEIN(A1);KLEIN(A2);"|";WENN(WENN(A3=0;1;A3)>(LÄNGE(A1)-LÄNGE(WECHSELN(KLEIN(A1);KLEIN(A2);"")))/LÄNGE(A2);(LÄNGE(A1)-LÄNGE(WECHSELN(KLEIN(A1);KLEIN(A2);"")))/LÄNGE(A2);WENN(A3=0;1;A3))));0)